How can we make Planner better?

Date format

The date format is fixed to mm/dd/yyyy, could this please be selectable based on your region - for example we use dd/mm/yyyy

Thanks

1,254 votes
Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)

We’ll send you updates on this idea

Anonymous shared this idea  ·   ·  Flag idea as inappropriate…  ·  Admin →
Completed  ·  AdminPlanner Team (Product Manager, Planner) responded  · 

Hello!

We’ve completed the work to reflect the proper date format based on a user’s Office 365 language setting.

If you’re still having issues with this, please send us feedback through the settings menu (Gear icon in web app or mobile apps) so we can further improve this experience.

Thank you for your feedback and patience,
The Planner Team

236 comments

Sign in
(thinking…)
Sign in with: facebook google
Signed in as (Sign out)
Submitting...
  • Anonymous commented  ·   ·  Flag as inappropriate

    Dear Admin team ,

    Please fix it , is the setting in office 365 admin settings or planner settings?

  • Mark commented  ·   ·  Flag as inappropriate

    Agreed with Anonymous April 13... Is there a way to set default planner (in browser) links to include /en-au/ based on Tennant location?

    Anonymous April 13 - I've found that if your personal account (language) settings in Teams is set to 'English AU' then the date format seems to format correctly based on those... but still doesn't reformat in browser.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Just embedded a Planner in Teams for my first experience at using Planner; and have hit this date issue.

    Going to make it very painful for us (Australia)

  • David Cooper commented  ·   ·  Flag as inappropriate

    Hi Product Group,

    How did this even pass testing? I’ve raised a support issue as to me this is now a defect as you have stated it’s fixed.

  • Stuart commented  ·   ·  Flag as inappropriate

    I am unable to get off the US date in the Planner tab in Teams app. i have set the language to English (Australia) in my profile but it makes no difference.

    what am i doing wrong as its infuriating!

  • Damien commented  ·   ·  Flag as inappropriate

    Hi Planner team,

    still wrong region when choosing the Planner icon.

    Link on Portal is en-GB
    Link on app picker whilst in SharePoint is en-US
    Link on app picker whilst in Outlook webmail is en-AU
    Link on app picker whilst in Word Online is en-GB

    So still all over the place.
    I have checked with a second user with identical results.

    Our region is Australia.

  • Hayden G commented  ·   ·  Flag as inappropriate

    @Planner Team. Recommendation: get new testers. Old ones suck. Mark as 'In progress', apologise for celebrating too early, and revisit drawing board.

  • Anonymous commented  ·   ·  Flag as inappropriate

    Not working! I have it set to ISO 8601 (YYYY-MM-DD) and it's displaying as MM/DD/YYYY.

  • MRP commented  ·   ·  Flag as inappropriate

    Not working. Please don't mark things as "Completed" when you haven't actually fixed anything. This should be re-opened immediately

  • James Ward commented  ·   ·  Flag as inappropriate

    Where is the language meant to be set? Mine is set correctly (EN-GB) in OWA, but I don't have access to the settings section of 365 (totalit IT team). Is this where it should be done?

  • Matt commented  ·   ·  Flag as inappropriate

    Agreed this doesn't work.
    If I go to Planner through the office 365 waffle menu I get to change the URL to match EN-GB (I cant force my users to do this!!!!! but when I am embedding a Plan into a modern SharePoint team site, the URL is enforced by Microsoft and I don't think I can change it, it always uses a US format, no matter that my SharePoint site Regional Settings are set to English-UK.

    A royal pain in the butt!
    Please get this fixed Microsoft

  • Anonymous commented  ·   ·  Flag as inappropriate

    An option to select date acc to standard, (ISO8601) should be available (in all office applications).

  • Scott Jackson commented  ·   ·  Flag as inappropriate

    It has improved, but not fully solved as there are still some links from the waffle menu on the top left that are not honouring the local settings. I am getting some success if I start from the Office 365 main llink ( and don't use the waffle). Feedback submitted via the cog wheel as requested.

  • John Gillanders commented  ·   ·  Flag as inappropriate

    There is still one thing wrong (I have just reported it through the gear icon as you requested, Planner Team):
    When opening Planner from the apps shortcut, it uses a URL which contains the language code 'en-US' instead of loading the correct version with the correct language (tested just now and it's still doing this).

    As a work-around, you can change the URL in web browsers address bar by manually editing the part that says 'en-US' and change it to your actual language code (e.g. 'en-NZ', 'en-AU', 'en-UK', etc.) Then make a bookmark to that and use that instead of the shortcut from the Microsoft 365 'apps' menu.

  • Grant commented  ·   ·  Flag as inappropriate

    In our Microsoft Teams Desktop App, my language settings are set to English (Australia), and when I view my Planner within the Teams app it displays the correct format (this has been working for a long time).

    The issue is when using the Planner web app. My Office 365 time zone/region settings are set to Brisbane and English (Australia) respectively, but Planner still shows US format.

    So I don't see any change?

  • David Cooper commented  ·   ·  Flag as inappropriate

    Hi Product Manager

    I'm still getting us date formats when I use the app launcher in sharepoint and if I select planner within the app it changes me to us format. Is this really fixed?

← Previous 1 3 4 5 11 12

Feedback and Knowledge Base